dpogue opened a new issue, #1428: URL: https://github.com/apache/cordova-ios/issues/1428
# Feature Request ## Motivation Behind Feature <!-- Why should this feature be implemented? What problem does it solve? --> `CDVPlugin` has a `viewController` property that is currently typed as `UIViewController*`. However, it is only ever set from within `CDVViewController` and is always set to a `CDVViewController*` instance. ## Feature Description <!-- Describe your feature request in detail Please provide any code examples or screenshots of what this feature would look like Are there any drawbacks? Will this break anything for existing users? --> We should just update the `CDVPlugin` API so that `viewController` is typed as `CDVViewController*` rather than `UIViewController*`. Since `CDVViewController` is a subclass of `UIViewController` this shouldn't break any plugins, but it is an API change and should be handled in the next major. ## Alternatives or Workarounds <!-- Describe alternatives or workarounds you are currently using Are there ways to do this with existing functionality? --> Currently the standard practice is to just cast `(CDVViewController*)self.viewController` everywhere, which works fine but is kinda annoying. -- This is an automated message from the Apache Git Service. To respond to the message, please log on to GitHub and use the URL above to go to the specific comment. To unsubscribe, e-mail: issues-unsubscr...@cordova.apache.org.apache.org For queries about this service, please contact Infrastructure at: us...@infra.apache.org --------------------------------------------------------------------- To unsubscribe, e-mail: issues-unsubscr...@cordova.apache.org For additional commands, e-mail: issues-h...@cordova.apache.org