[
https://issues.apache.org/jira/browse/FILEUPLOAD-254?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15932497#comment-15932497
]
Dmitry Katsubo commented on FILEUPLOAD-254:
-------------------------------------------
I vote for this improvement. I think the issue is similar to FILEUPLOAD-278. I
would suggest the method name like:
{code}
public InputStream getBodyDataInputStream();
{code}
or simply
{code}
public InputStream getInputStream();
{code}
> Improve MultipartStream public API
> ----------------------------------
>
> Key: FILEUPLOAD-254
> URL: https://issues.apache.org/jira/browse/FILEUPLOAD-254
> Project: Commons FileUpload
> Issue Type: Improvement
> Affects Versions: 1.3.1
> Reporter: Anton Gorbunov
> Assignee: Jochen Wiedmann
>
> In many cases user may need to get part content as an InputStream.
> MultipartStream class already has such method - newInputStream(), but for
> some reason it made package-private.
> I suggest to make it public.
--
This message was sent by Atlassian JIRA
(v6.3.15#6346)