[
https://issues.apache.org/jira/browse/COMPRESS-656?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17804826#comment-17804826
]
Vali Maties edited comment on COMPRESS-656 at 1/9/24 5:47 PM:
--------------------------------------------------------------
Looking in SevenZOutputFile class, where the ArchiveEntry is closed, in the
closeArchiveEntry method, fileBytesWritten seems to be the value of packed
size. I added a property to this class to sum the fileBytesWritten from this
method. But in the end, comparing the size of the archive and this summed value
there is a little difference. Is this the header size?
was (Author: JIRAUSER303742):
Looking in SevenZOutputStream, where the ArchiveEntry is closed, in the
closeArchiveEntry method, fileBytesWritten seems to be the value of packed
size. I added a property to this class to sum the fileBytesWritten from this
method. But in the end, comparing the size of the archive and this summed value
there is a little difference. Is this the header size?
> SevenZArchiveEntry getCompressedSize() must be public
> -----------------------------------------------------
>
> Key: COMPRESS-656
> URL: https://issues.apache.org/jira/browse/COMPRESS-656
> Project: Commons Compress
> Issue Type: Improvement
> Components: Compressors
> Affects Versions: 1.25.0
> Reporter: Vali Maties
> Priority: Major
> Labels: SevenZArchiveEntry, entry-compressed-size
> Attachments: EntryCompressedSizePrivate.png, OriginalFileSize.png
>
>
> Please make the compressedSize property of SevenZArchiveEntry as observable
> property with getter. Having this property as observable, we can know in
> anytime the compressed size of an entry. Or maybe only a getter to existing
> compressedSize property.
> I've attached two screenshots with both original file size and the compressed
> size in SevenZArchiveEntry class, running my project in debbug.
>
> _*Edited:*_
> I've saw right now that already exists a getCompressedSize() method, but is
> private. Make that public, to be accessible, please.
--
This message was sent by Atlassian Jira
(v8.20.10#820010)