[ https://issues.apache.org/jira/browse/CLOUDSTACK-10364?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16459751#comment-16459751 ]
ASF subversion and git services commented on CLOUDSTACK-10364: -------------------------------------------------------------- Commit 503b2c649c342ab7c463eb02cb5513c818281c6c in cloudstack's branch refs/heads/master from [~BruceKuiLIU] [ https://gitbox.apache.org/repos/asf?p=cloudstack.git;h=503b2c6 ] CLOUDSTACK-10364: Change the "setXXX" method names to "generateXXX" (#2601) The three methods are named as "setXXX", actually, they are not simple setter or getter. They are further renamed as "generateXXX" with dahn's comments. > Inconsiste "setXXX" method names. > --------------------------------- > > Key: CLOUDSTACK-10364 > URL: https://issues.apache.org/jira/browse/CLOUDSTACK-10364 > Project: CloudStack > Issue Type: Improvement > Security Level: Public(Anyone can view this level - this is the > default.) > Reporter: KuiLIU > Priority: Major > > The following two methods are named as "setXXX", > actually, they are not setter but getter. > Thus, they should be renamed as "getXXX". > {code:java} > private String setVnetBrName(String pifName, String vnetId) { > return "br" + pifName + "-" + vnetId; > } > private String setVxnetBrName(String pifName, String vnetId) { > return "brvx-" + vnetId; > } > {code} -- This message was sent by Atlassian JIRA (v7.6.3#76005)