Claus Ibsen created CAMEL-25131:
-----------------------------------

             Summary: Checks of Camel header names should be case-insensitive
                 Key: CAMEL-25131
                 URL: https://issues.apache.org/jira/browse/CAMEL-25131
             Project: Camel
          Issue Type: Bug
          Components: camel-core
            Reporter: Claus Ibsen


Message headers are case-insensitive, so a Camel header can be named Camel*, 
camel*, CAMEL* or any other case. Some code checks for Camel headers with a 
case-sensitive key.startsWith("Camel"):

* camel-tracing: CamelHeadersInjectAdapter, CamelMessagingHeadersInjectAdapter
* camel-telemetry: CamelHeadersSpanContextPropagationInjector, 
CamelJMSHeadersSpanContextPropagationInjector
* camel-netty-http: DefaultNettyHttpBinding.copyCamelHeaders, 
NettyHttpProducer.removeCamelHeaders
* camel-support: DefaultExchangeHolder (log level of headers that cannot be 
serialized)

These should match the Camel prefix in any case (as DefaultHeaderFilterStrategy 
already does).



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

Reply via email to