[ 
https://issues.apache.org/jira/browse/CAMEL-24895?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Andrea Cosentino updated CAMEL-24895:
-------------------------------------
    Fix Version/s: 4.22.2
                   4.18.5

> camel-mustache, camel-chunk - align Exchange header constant names with Camel 
> naming convention
> -----------------------------------------------------------------------------------------------
>
>                 Key: CAMEL-24895
>                 URL: https://issues.apache.org/jira/browse/CAMEL-24895
>             Project: Camel
>          Issue Type: Task
>          Components: camel-chunk
>            Reporter: Andrea Cosentino
>            Assignee: Andrea Cosentino
>            Priority: Major
>             Fix For: 4.18.5, 4.22.2, 4.23.0
>
>
> The {{camel-mustache}} and {{camel-chunk}} components define their 
> template/resource exchange-header constants without the {{Camel}} prefix:
> * {{MustacheConstants}}: {{MustacheResourceUri}}, {{MustacheTemplate}}
> * {{ChunkConstants}}: {{ChunkResourceUri}}, {{ChunkTemplate}}
> Every other template/transform engine on the same {{allowTemplateFromHeader}} 
> surface (freemarker, velocity, mvel, stringtemplate, thymeleaf, jte, jolt, 
> jslt, jsonata, xslt) already follows the {{Camel*}} naming convention, so 
> that {{DefaultHeaderFilterStrategy}} handles them consistently at trust 
> boundaries (see {{design/headers.adoc}}). These two components were not 
> covered by that alignment.
> Change: rename the constants to {{CamelMustacheResourceUri}} / 
> {{CamelMustacheTemplate}} and {{CamelChunkResourceUri}} / 
> {{CamelChunkTemplate}}, retaining the old string values for backward 
> compatibility (deprecate, do not hard-break), update references in the 
> endpoints and docs, regenerate the catalog, and add an upgrade-guide entry. 
> Continuation of the CAMEL-23577 header-alignment work.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

Reply via email to