[ 
https://issues.apache.org/jira/browse/CAMEL-21284?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Nicolò Scarpa updated CAMEL-21284:
----------------------------------
    Description: 
The new {{camel-clickup}} component relies on the {{camel-webhook}} 
(meta-)component for providing webhook functionality. This is actually the 
[encouraged 
design|https://camel.apache.org/components/4.8.x/webhook-component.html] for 
implementing new webhooks capable components, but it's a bit hacky since the 
specialized component won't be actually used as an endpoint, but it would be 
rather used as the _delegate_ for the {{camel-webhook}} component (i.e. the URI 
for creating a {{camel-clickup}} endpoint is 
{{"webhook:clickup:<workspaceId>"}}, instead of {{"clickup:<workspaceId>"}}).

See if it's possibile to make camel-webhook reusable by other components, so no 
code duplication is needed to implement webhook functionality.

Its fine to have {{camel-webhook}} in pom.xml, but make the clickup as a pure 
component without the "webhook:xxx" prefix in its URI.

In other words, the goal is to make clickup a first-class component that is 
like others and also tooling/dsl friendly.

  was:
The new {{camel-clickup}} component relies on the {{camel-webhook}} 
(meta-)component for providing webhook functionality. This is actually the 
[encouraged 
design|https://camel.apache.org/components/4.8.x/webhook-component.html] for 
implementing new webhooks capable components, but it's a bit hacky since the 
specialized component won't be actually used as an endpoint, but it would be 
rather used as the _delegate_ for the {{camel-webhook}} component.

See if it's possibile to make camel-webhook reusable by other components, so no 
code duplication is needed to implement webhook functionality.

Remove the {{camel-webook}} dependency from this component and implement the 
actual webhook behavior directly in the {{camel-clickup}} component.

The goal is to make clickup a first-class component that is like others and 
also tooling / dsl friendly.


> camel-clickup: remove dependency from camel-webhook
> ---------------------------------------------------
>
>                 Key: CAMEL-21284
>                 URL: https://issues.apache.org/jira/browse/CAMEL-21284
>             Project: Camel
>          Issue Type: Improvement
>    Affects Versions: 4.9.0
>            Reporter: Nicolò Scarpa
>            Priority: Major
>             Fix For: 4.9.0
>
>   Original Estimate: 72h
>  Remaining Estimate: 72h
>
> The new {{camel-clickup}} component relies on the {{camel-webhook}} 
> (meta-)component for providing webhook functionality. This is actually the 
> [encouraged 
> design|https://camel.apache.org/components/4.8.x/webhook-component.html] for 
> implementing new webhooks capable components, but it's a bit hacky since the 
> specialized component won't be actually used as an endpoint, but it would be 
> rather used as the _delegate_ for the {{camel-webhook}} component (i.e. the 
> URI for creating a {{camel-clickup}} endpoint is 
> {{"webhook:clickup:<workspaceId>"}}, instead of {{"clickup:<workspaceId>"}}).
> See if it's possibile to make camel-webhook reusable by other components, so 
> no code duplication is needed to implement webhook functionality.
> Its fine to have {{camel-webhook}} in pom.xml, but make the clickup as a pure 
> component without the "webhook:xxx" prefix in its URI.
> In other words, the goal is to make clickup a first-class component that is 
> like others and also tooling/dsl friendly.



--
This message was sent by Atlassian Jira
(v8.20.10#820010)

Reply via email to