Hello,
looking at console related code, I noted that the various cvars don't
have a consistent and "easy to guess" name scheme, for instance:
* scr_conspeed - set the scrolling speed to display the console
* con_notifytime - set the amount of time the notifications are displayed
* cl_consoleKeys - set the alternative keys used to bring the console
down
* cl_conXOffset - set the horizontal offset to display the text in
the console
There may be others but this is the minimal set I'm thinking of. So here
we have 3 different prefixes ('scr_', 'con_', both used nowhere else,
and 'cl_') and 2 ways of targetting the console (either with 'con' or
'console').
Working on a custom engine, I added some cvars for stuff about the
console (ie, using a shader or a plain color, choosing the console size,
...) and I'd like to see a consistent cvar naming scheme.
I'll probably break compatibility for my own needs but I think it could
be something done at the ioq3 level (not to break the compatibility but
to change the naming scheme ^^). Do you think that going to a coherent
cvar nameset could be valuable/useful for ioq3 ? And, in current state,
is there a (clean or immediate) way to support legacy cvars while
adding/changing some of them? I suppose that if some cvars are renammed,
say 'scr_conspeed' becomes 'cl_conSpeed' the need to support legacy
users implies the need to support legacy cvar names?
Have a nice day
_______________________________________________
ioquake3 mailing list
ioquake3@lists.ioquake.org
http://lists.ioquake.org/listinfo.cgi/ioquake3-ioquake.org
By sending this message I agree to love ioquake3 and libsdl.