On 2022/5/20 00:39, Jean-Philippe Brucker wrote:
+struct iommu_sva *iommu_sva_bind_device(struct device *dev, struct mm_struct 
*mm)
+{
+       struct iommu_sva_domain *sva_domain;
+       struct iommu_domain *domain;
+       ioasid_t max_pasid = 0;
+       int ret = -EINVAL;
+
+       /* Allocate mm->pasid if necessary. */
+       if (!dev->iommu->iommu_dev->pasids)
+               return ERR_PTR(-EOPNOTSUPP);
+
+       if (dev_is_pci(dev)) {
+               max_pasid = pci_max_pasids(to_pci_dev(dev));
+               if (max_pasid < 0)
+                       return ERR_PTR(max_pasid);
+       } else {
+               ret = device_property_read_u32(dev, "pasid-num-bits",
+                                              &max_pasid);
+               if (ret)
+                       return ERR_PTR(ret);
+               max_pasid = (1UL << max_pasid);
+       }
The IOMMU driver needs this PASID width information earlier, when creating
the PASID table (in .probe_device(), .attach_dev()). Since we're moving it
to the IOMMU core to avoid code duplication, it should be done earlier and
stored in dev->iommu

Yes, really. How about below changes?

From f1382579e8a15ca49acdf758d38fd36451ea174d Mon Sep 17 00:00:00 2001
From: Lu Baolu <baolu...@linux.intel.com>
Date: Mon, 28 Feb 2022 15:01:35 +0800
Subject: [PATCH 1/1] iommu: Add pasids field in struct dev_iommu

Use this field to save the number of PASIDs that a device is able to
consume. It is a generic attribute of a device and lifting it into the
per-device dev_iommu struct could help to avoid the boilerplate code
in various IOMMU drivers.

Signed-off-by: Lu Baolu <baolu...@linux.intel.com>
---
 drivers/iommu/iommu.c | 15 +++++++++++++++
 include/linux/iommu.h |  2 ++
 2 files changed, 17 insertions(+)

diff --git a/drivers/iommu/iommu.c b/drivers/iommu/iommu.c
index e49c5a5b8cc1..6b731171d42f 100644
--- a/drivers/iommu/iommu.c
+++ b/drivers/iommu/iommu.c
@@ -20,6 +20,7 @@
 #include <linux/idr.h>
 #include <linux/err.h>
 #include <linux/pci.h>
+#include <linux/pci-ats.h>
 #include <linux/bitops.h>
 #include <linux/property.h>
 #include <linux/fsl/mc.h>
@@ -194,6 +195,8 @@ EXPORT_SYMBOL_GPL(iommu_device_unregister);
 static struct dev_iommu *dev_iommu_get(struct device *dev)
 {
        struct dev_iommu *param = dev->iommu;
+       u32 max_pasids = 0;
+       int ret;

        if (param)
                return param;
@@ -202,6 +205,18 @@ static struct dev_iommu *dev_iommu_get(struct device *dev)
        if (!param)
                return NULL;

+       if (dev_is_pci(dev)) {
+               ret = pci_max_pasids(to_pci_dev(dev));
+               if (ret > 0)
+                       max_pasids = ret;
+       } else {
+               ret = device_property_read_u32(dev, "pasid-num-bits",
+                                              &max_pasids);
+               if (!ret)
+                       max_pasids = (1UL << max_pasids);
+       }
+       param->pasids = max_pasids;
+
        mutex_init(&param->lock);
        dev->iommu = param;
        return param;
diff --git a/include/linux/iommu.h b/include/linux/iommu.h
index 45f274b2640d..d4296136ba75 100644
--- a/include/linux/iommu.h
+++ b/include/linux/iommu.h
@@ -371,6 +371,7 @@ struct iommu_fault_param {
  * @fwspec:     IOMMU fwspec data
  * @iommu_dev:  IOMMU device this device is linked to
  * @priv:       IOMMU Driver private data
+ * @pasids:     number of supported PASIDs
  *
  * TODO: migrate other per device data pointers under iommu_dev_data, e.g.
  *     struct iommu_group      *iommu_group;
@@ -382,6 +383,7 @@ struct dev_iommu {
        struct iommu_fwspec             *fwspec;
        struct iommu_device             *iommu_dev;
        void                            *priv;
+       u32                             pasids;
 };

 int iommu_device_register(struct iommu_device *iommu,
--
2.25.1

Best regards,
baolu
_______________________________________________
iommu mailing list
iommu@lists.linux-foundation.org
https://lists.linuxfoundation.org/mailman/listinfo/iommu

Reply via email to