On Sat, Nov 14, 2020 at 10:17:10AM -0500, Jonathan Marek wrote: > Add a function to force direct ops and disable swiotlb for a deivce.
s/deivce/device/ > +#if IS_ENABLED(CONFIG_DMA_OPS_BYPASS) && > !IS_ENABLED(CONFIG_ARCH_HAS_FORCE_DMA_UNENCRYPTED) overly long line. > +#if IS_ENABLED(CONFIG_DMA_OPS_BYPASS) && > !IS_ENABLED(CONFIG_ARCH_HAS_FORCE_DMA_UNENCRYPTED) Again. > +int dma_direct_bypass(struct device *dev) > +{ > + int ret; > + > + ret = dma_set_mask_and_coherent(dev, DMA_BIT_MASK(64)); > + if (ret) > + return ret; > + > + dev->bus_dma_limit = DMA_BIT_MASK(64); > + dev->dma_ops_bypass = true; > + return 0; > +} > +EXPORT_SYMBOL_GPL(dma_direct_bypass); But more importantly ARCH_HAS_FORCE_DMA_UNENCRYPTED is just a compile time flag. With this you disable the functionality for all the usual x86, s390 and powerpc configs, while only a tiny number of systems for bounce buffering. But I think you can just trivialy check force_dma_unencrypted instead. We do not need an extra Kconfig symbol symbol for this trivial helper. Also the helper is misnamed and misplaced. The semantics have nothing to do with dma-direct, the fact that is uses the ops bypass is an implementation detail. It really fits into the iommu code, as it allows the driver to use the IOMMU API for IOVA management, while using the DMA API for cache management. So it should be named to reflect that, and also grow a kerneldoc comment explaining how it will be used. _______________________________________________ iommu mailing list iommu@lists.linux-foundation.org https://lists.linuxfoundation.org/mailman/listinfo/iommu