Hi Arnd, On Thu, Mar 7, 2019 at 9:01 AM Arnd Bergmann <a...@arndb.de> wrote: > Clang has a rather annoying behavior of checking for integer > arithmetic problems in code paths that are discarded by gcc > before that perfoms the same checks. > > For DMA_BIT_MASK(64), this leads to a warning despite the > result of the macro being completely sensible: > > arch/arm/plat-iop/adma.c:146:24: error: shift count >= width of type > [-Werror,-Wshift-count-overflow] > .coherent_dma_mask = DMA_BIT_MASK(64), > > The best workaround I could come up with is to shift the > value twice, which makes the macro way less readable but > always has the same result. > > Link: https://bugs.llvm.org/show_bug.cgi?id=38789 > Signed-off-by: Arnd Bergmann <a...@arndb.de> > --- > include/linux/dma-mapping.h | 3 ++- > 1 file changed, 2 insertions(+), 1 deletion(-) > > diff --git a/include/linux/dma-mapping.h b/include/linux/dma-mapping.h > index 75e60be91e5f..380d3a95d02e 100644 > --- a/include/linux/dma-mapping.h > +++ b/include/linux/dma-mapping.h > @@ -138,7 +138,8 @@ struct dma_map_ops { > extern const struct dma_map_ops dma_virt_ops; > extern const struct dma_map_ops dma_dummy_ops; > > -#define DMA_BIT_MASK(n) (((n) == 64) ? ~0ULL : ((1ULL<<(n))-1)) > +/* double shift to work around https://bugs.llvm.org/show_bug.cgi?id=38789 */ > +#define DMA_BIT_MASK(n) (((n) == 64) ? ~0ULL : (((1ULL<<((n)-1))-1) > << 1))
The second "-1" should be done on the final result, not on the intermediate value. Gr{oetje,eeting}s, Geert -- Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- ge...@linux-m68k.org In personal conversations with technical people, I call myself a hacker. But when I'm talking to journalists I just say "programmer" or something like that. -- Linus Torvalds _______________________________________________ iommu mailing list iommu@lists.linux-foundation.org https://lists.linuxfoundation.org/mailman/listinfo/iommu