domain_has_cap is a misnomer bc the func name should be 
the same for CONFIG_IOMMU_API and !CONFIG_IOMMU_API.

Signed-off-by: Upinder Malhi <uma...@cisco.com>
---
 include/linux/iommu.h | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/include/linux/iommu.h b/include/linux/iommu.h
index 7ea319e..7bb795c 100644
--- a/include/linux/iommu.h
+++ b/include/linux/iommu.h
@@ -289,8 +289,8 @@ static inline phys_addr_t iommu_iova_to_phys(struct 
iommu_domain *domain, dma_ad
        return 0;
 }

-static inline int domain_has_cap(struct iommu_domain *domain,
-                                unsigned long cap)
+static inline int iommu_domain_has_cap(struct iommu_domain *domain,
+                                      unsigned long cap)
 {
        return 0;
 }
-- 
1.8.1

_______________________________________________
iommu mailing list
iommu@lists.linux-foundation.org
https://lists.linuxfoundation.org/mailman/listinfo/iommu

Reply via email to