wrote in message
news:9dffe898-e550-c6d6-46bd-86dcf7473...@fleshgrinder.com...
Hey guys!
People are complaining over at Reddit [1] about using PHP, Std, UUID,
... in other words about case.
I know that this is probably a topic nobody cares much about, at least
we did not end up in this kind of bikeshedding in the UUID discussion
thread, but it is after all an important question when designing a
language.
Our coding standards are extremely unspecific about this kind of
problem, the only thing that is written there is to avoid abbreviations,
and acronyms are not mentioned at all:
https://github.com/php/php-src/blob/master/CODING_STANDARDS#L154-L166
The question is, what would you guys want? The PHP community that
follows the PSR rules is using PascalCase everywhere. The PHP core is
inconsistent:
The notion that this little inconsistency causes a problem only exists in
the minds of nit-pickers and OCD sufferers. The definition of
"inconsistency" can be taken to ridiculous extremes, as in the following
examples:
- class/method names don't all begin with the same letter - that's
inconsistent.
- class/method names don't all contain the same number of characters -
that's inconsistent.
- class/method names don't all contain the same number of vowels and
consonants - that's inconsistent.
- class/method names don't all contain the same number of uppercase and
lowercase characters - that's inconsistent.
The very idea that there is a "standard" naming convention that everyone
should follow I find most objectionable. The only universal standard is that
every name be readable and convey meaning. Different
projects/teams/organisations are free to use whatever naming convention they
like, be it snake_case, CamelCase, studlyCaps or whatever, and they should
not be forced to change just because some nerd has made a unilateral
decision which is way above his pay grade.
In my project I use a mixture of styles just because I can, but as each name
is readable and conveys meaning it does not cause a problem, therefore does
not require any sort of solution.
There are more important changes which can be made to the language other
than changing it to comply with someone's personal preferences, so this
ridiculous idea should be kicked into the long grass.
Just my personal opinion.
--
Tony Marston
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php