Hi Rowan,

On Wed, Mar 11, 2015 at 9:32 PM, Rowan Collins <rowan.coll...@gmail.com>
wrote:

> Lester Caine wrote on 10/03/2015 21:12:
>
>> On 10/03/15 20:44, Yasuo Ohgaki wrote:
>>
>>> YES there is room to create a more consistent procedural interface, but
>>>>> my original question still applies "consistent with what rules?"
>>>>>
>>>> It's possible choice.
>>> I agree that names without "_" looks more consistent.
>>> Personally, I don't care much about having "_" or not for procedural
>>> API. My
>>> only concern is naming consistency.
>>>
>>> Names without "_" changes basic coding rule.
>>> Problem is how to make a choice and how to define exceptions. e.g.
>>> nl_langinfo()
>>>
>>> I wonder how many of us prefer names without "_".
>>>
>> The one thing that your RFC demonstrates perfectly is just how much has
>> to change to match that rule. Change the rule and the number of names
>> that need alternatives is considerably less. I know a case was made at
>> the time for adding underscores to the guidelines but it's quite clear
>> that this was the mistake?
>>
>
> PHP function names are case insensitive, and conventionally written in
> lower-case (a convention that nothing decided on this list will change), so
> underscores are important for readability.
>
> To take an example Yasuo has mentioned a couple of times, pg_lo_open()
> without any underscores at all would be pgloopen(), which is very hard to
> read: it could be pGloopen(), pgLoopEn(), pGlooPen(), pgLoOpen(), etc.
>
> For whatever reason, PHP's users decided to go with camelCase identifiers
> for methods, rather than underscores. I don't think that was a decision
> that originated in the core distribution (which for a long time had very
> few object APIs), and I don't think it's one that can be changed by the
> core distribution (or, at this stage, anyone).
>
> If PHP had had namespaces from day 1, and camel-case conventions, it would
> have been pg\loOpen(), but we can't change history.
>

We cannot change history, so we have to make choice that is feasible.
I think use of "_" wasn't too bad. PHP stores function names as lower cased
names.
Therefore, error message says "Warning some error in
imagecolorclosesthwb()", etc.
It's hard to read, indeed. It also encourage users to use
"imagecolorclosesthwb" as
official name...

It may be better to consider how namespace for internals should be used.
Otherwise,
we may have to rename functions/namespaces again in the future. It may be
for PHP8.
It may be for PHP7.x if changes are not destructive at all.

Having namespace for internals would bring much flexibility for API
changes, both
OO and procedural API. I may try my best to have consensus.

I think you also like to have OO style API for basic
variables(int/float/array) as I am.
Unless we have good/proper procedural API names, it would be an obstacle to
have
OO style API for basic variables. I wish you agree to do something for it.

Regards,

--
Yasuo Ohgaki
yohg...@ohgaki.net

Reply via email to