On 31 January 2015 at 17:31, Philip Sturgeon <pjsturg...@gmail.com> wrote:
> On Sat, Jan 31, 2015 at 3:12 AM, Matteo Beccati <p...@beccati.com> wrote:
>>
>> 2) There's a tiny bit of overlap with "scalar type hints",
>
> 2) There might be some overlap in the scalar type hint stuff kinda,
> but I'd like to think there isn't. getClassName() is just
> getClass()->name


I think Matteo's point is that if any scalar type RFC passes, a
type-hint for a parameter would not always be the name of a class, so
the method name 'getClassName()' would be misleading.

It would be good to choose a better name to avoid that problem.

cheers
Dan

-- 
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to