Hi Andrea,

On Mon, Jan 12, 2015 at 7:12 AM, Andrea Faulds <a...@ajf.me> wrote:

>   * Get rid of rand(), srand() and getrandmax()
>   * Rename mt_rand(), mt_srand() and mt_getrandmax() to rand(), srand(),
> and getrandmax() but add mt_* aliases for backwards-compatibility
>   * Make mt_srand() and srand() do nothing and produce a deprecation notice
>   * Use a 64-bit random number generation algorithm on 64-bit platforms
> (or invoke the 32-bit generator twice)
>

I like your proposal in general.

However, I object removal of srand.
Game programmers need "the same random sequence" on occasion.
There should be srand to get the same sequence for repeatable behaviors.

rand()/srand() may be renamed to sys_rand()/sys_srand() (or whatever
suitable name for them) in case user needs system random sequence
for whatever reasons. I don't insist to keep system's rand/srand, though.

Regards,

--
Yasuo Ohgaki
yohg...@ohgaki.net

Reply via email to