On Wed, Oct 23, 2013 at 3:20 AM, Yasuo Ohgaki <yohg...@ohgaki.net> wrote:

> Hi Andrea,
>
> On Wed, Oct 23, 2013 at 9:26 AM, Andrea Faulds <a...@ajf.me> wrote:
>
> > But it already exists. Why add *another* alias? We should make
> > apache_response_headers() have a consistent alias, something like
> > getresponseheaders(). Then we'll have:
> >
> > * apache_request_headers() and getallheaders()
> > * apache_response_headers() and getresponseheaders()
> >
> > Under your proposal, we'd have:
> >
> > * apache_request_headers(), sapi_request_headers(), and getallheaders()
> > * apache_response_headers() and sapi_response_headers()
> >
>
> It is not good idea introducing non-standard function name in new releases.
> getallheaders() should be depreciated in the future as it does not conform
> current naming convention.
>
> How about this?
>
> PHP 5.6: Document getallhaeders() as deprecated.
> PHP 5.7: Raise deprecated error for getallheaders().
> PHP 6.x: Remove getallheaders() adoption is done. (Perhaps 5 or 10 years
> from now?)
>
> It would be nicer cleaning up mess in the long run, rather than
> introducing new mess. IMHO.
>
> Regards,
>
> --
> Yasuo Ohgaki
> yohg...@ohgaki.net
>

I would stick with the original proposal as it is a well understood and
self-contained feature with neglible/no BC break.
Handling the (possible) deprecation and removal of the apache_ functions
should be a separate topic(if you start walking down on that path, you have
to also consider other functions like apache_child_terminate which is also
provided by the cgi-fastcgi SAPI) and should be given a bit more thought
and because of the BC implications it is also a longer process(as you also
mentioned yourself).
Thanks for your feedback!

-- 
Ferenc Kovács
@Tyr43l - http://tyrael.hu

Reply via email to