On Thu, Jun 27, 2013 at 4:10 PM, Christian Stoller <stol...@leonex.de>wrote:

> The new syntax could make it shorter and faster to write... but maybe it's
> a bit too confusing?
>
> $count = 0;
> foreach ($array as $key => $innerArray as $innerKey => $value) {
>     $count += $value;
>     // and do something with $key and $innerKey
> }
>

I'm against this feature. It makes the code marginally shorter, but a good
bit less readable. Combined with the break/continue issue, I don't think we
gain anything by introducing this syntax.

Nikita

Reply via email to