On 05/04/2013 08:28 AM, Laruence wrote:
>   and inefficent not always means performance only,  in this case , you
> need to define various functions for different regexs if you use loop style.
> 
>   and do you prefer array_walk or foreach when you try to iteraterly
> process an array?

I certainly prefer foreach over array_walk/array_map because I think the
resulting code is easier to read. It also happens to be faster to use
foreach in every case I have ever tested.

-Rasmus

-- 
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to