On Aug 17, 2005, at 10:27 AM, Dmitry Stogov wrote:

Zend/zend_API.c:
   zend_error(error_type, "Method %s%s%s() cannot be a NULL
function",
scope ? scope->name : EMPTY_STR, scope ? "::" : "", ptr->fname);

This place doesn't need EMPTY_STR. ("" is enough)

If EMPTY_STR is supposed to be used only in Unicode context, we should make it clear, by naming it U_EMPTY_STR and then replacing all instances of EMPTY_STR with it or "" as necessary.

-Andrei
--
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to