Magnus Määttä wrote: > I don't see how putting a name on the number makes it any better and I > still would have to emulate it with loops and breaks and continues, > unless it's actually a code word for goto ;)
your code with named breaks/continues: continue_label: for (...; ...; ...) { break_label: for (...; ...; ...) { if (...) { ... code ... continue continue_label; } else { ... code ... break break_label; } } } I think, it's more readable and I can add loops without change labels. FYI: label break_label is redutand :) (in this case) -- Ondrej Ivanic ([EMAIL PROTECTED]) -- PHP Internals - PHP Runtime Development Mailing List To unsubscribe, visit: http://www.php.net/unsub.php