The RFC draft I put up that seems to have fell into the lost stack might be
coupled with this. If I'm going to run that command, whatever it's called,
the namespace autoload process seems the logical place to do it to insure
it is called before the namespace is invoked the first time. Otherwise
you'll have to have this declare at the top of every file in the namespace
which could be awkward.

On Wed, Jul 15, 2026 at 5:14 AM Rowan Tommins [IMSoP] <[email protected]>
wrote:

> On 15 July 2026 01:54:32 BST, "Paul M. Jones" <[email protected]> wrote:
> >Hi all,
> >
> >Per feedback from Tim Tim Düsterhus <
> https://externals.io/message/131332#131899> I have extracted the
> `declare(strict_namespace=1)` portion of the function autoloading proposal
> to its own RFC.
>
>
> I said this already on the other thread, but if we're going to do this,
> please let's come up with a better name.
>
> "Strict" implies some extra check that namespaces are "correct" in some
> way, which isn't really what this is about. And without reading the manual
> (or RFC), I would genuinely have no idea if setting this to "1" meant "all
> namespaced names have to be qualified" or "all global names have to be
> qualified".
>
> There's also at least two prior RFCs on this subject which we should look
> back at:
>
> - https://wiki.php.net/rfc/fallback-to-root-scope-deprecation - 2017;
> proposed removing the fallback completely; discussed but never voted
> - https://wiki.php.net/rfc/use_global_elements - 2020; proposed a declare
> for global-only lookups; Declined
>
>
> There are probably other relevant threads in the list archives as well.
>
> Regards,
>
> Rowan Tommins
> [IMSoP]
>

Reply via email to