Hello everyone, I think we have reached a point where we should really consider a naming convention for build-in classes and interfaces. In my opinion, popular class names like "exception", "iterator" or "directory" should be left to user land.
Moreover we should make more use of interfaces for magical OO behavior like cloning, casting, serializing and overloading. Therefore my suggestion is to introduce following symbols: - class php_object instead of stdclass, since (object) $var represents an object and not a class. It is more meaningfull to create a new php_object() instead a new stdclass() - class php_exception instead of exception - interface php_cloneable for classes implementing the __clone() method - interface php_serializeable for classes implementing __sleep() and __wakeup() - interface php_overloadable for classes implementing __get(), __set() and __call() Maybe there is a better prefix than "php" to strictly separate Zend Engine from PHP. Examples are "zend_xxx", "zxxx" or "__xxx". -- Ferdinand Beyer <[EMAIL PROTECTED]> -- PHP Internals - PHP Runtime Development Mailing List To unsubscribe, visit: http://www.php.net/unsub.php