Hello internals, referring to paragraph 6 of our CODING_STYLES i changed my own spl extension and parts of SQLite which interact with spl.
[6] Method names follow the 'studlyCaps' (also referred to as 'bumpy case' or 'camel caps') naming convention, with care taken to minimize the letter count. The initial letter of the name is lowercase, and each letter that starts a new 'word' is capitalized. Good: 'connect()' 'getData()' 'buildSomeWidget()' Bad: 'get_Data()' 'buildsomewidget' 'getI()' This change immediatly caused stormy discussion on IRC. Here is what i think: * nobodycanreadysudlycapsmethods <- can you read that? That is what our error messages and the reflection output will contain instead of the intended nobodyCanReadySudlyCapsMethods what isn't much better. Anyway PHP isn't simply capable of handling sudlyCaps since we need to input method names in lowercase. * When moving extensions from PHP4 to PHP5 we would sooner or later add newer features to their classes just like i did with SQLite. This does result in a mixture of the old and new naming conversion which is annoying. As the only consequence i think we should remove that part 6 from our CS. regards marcus -- Best regards, Marcus mailto:[EMAIL PROTECTED] -- PHP Internals - PHP Runtime Development Mailing List To unsubscribe, visit: http://www.php.net/unsub.php