This series moves ice_init_hw() call to be prior to ice_adapter init. To do so we need: (patch 1) move waiting for FW into ice_init_hw(); (patch 2) split ice_init_hw() out of ice_init_dev(), so it could be manually called in ice_init(). The change mandates similar split in ice_devlink_reinit_up(). To keep things consistent ice_deinit_hw() is also extracted to be called manually.
(Patch 4) finally changes the order in ice_probe() to move ice_adapter init past the ice_init_hw() call. Patch 3 does minor cleanup after patch 2, to keep diffs more readable. The whole motivation is to have ability to act on the number of PFs in ice_adapter initialization. This series is not doing that (but I've print-tested that such number is correct there). Code is also a bit cleaner, so overall it's good to go in an incremental fashion IMO. Przemek Kitszel (4): ice: c827: move wait for FW to ice_init_hw() ice: split ice_init_hw() out from ice_init_dev() ice: minor: rename goto labels from err to unroll ice: ice_probe: init ice_adapter after HW init drivers/net/ethernet/intel/ice/ice_common.h | 1 - .../net/ethernet/intel/ice/devlink/devlink.c | 10 +- drivers/net/ethernet/intel/ice/ice_common.c | 110 ++++++++++++------ drivers/net/ethernet/intel/ice/ice_main.c | 88 +++++--------- 4 files changed, 110 insertions(+), 99 deletions(-) base-commit: c94f1e05dfa83f1a8875111756c52955d721e60f -- 2.46.0