On Tue, Mar 24, 2015 at 10:14:01PM -0700, Matt Roper wrote:
> On Fri, Mar 20, 2015 at 05:04:26PM -0700, Chandra Konduru wrote:
> > +static void skl_init_scalers(struct drm_device *dev, int pipe,
> > +   struct intel_crtc_state *crtc_state)
> > +{
> > +   int i;
> > +   struct intel_scaler *intel_scaler;
> > +   struct intel_crtc_scaler_state *scaler_state = 
> > &crtc_state->scaler_state;
> > +   if (INTEL_INFO(dev)->gen < 9)
> > +           return;
> 
> It's probably better to move this guard out to the callsite so that we
> can more easily extend this for future platforms.  Unless you plan to
> just extend this function in the future, in which case we should
> probably drop the 'skl_' prefix.

Naming rule is that platform-specific stuff is named with the first
platform codename that uses it. So skl_ is still fine even if we extend
this for bxt or skl+1. intel_ should only be used for truly generic
driver-wide stuff.
-Daniel
-- 
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/intel-gfx

Reply via email to