On Thu, Mar 19, 2015 at 12:30:10PM +0000, john.c.harri...@intel.com wrote:
> +void intel_ring_reserved_space_use(struct intel_ringbuffer *ringbuf, int 
> size)

Just a bit of interface bikeshed - I'd drop the size parameter here. It
just duplicates what we tell the ring in the reservation code and the real
check happens in the _end function.

> +{
> +     WARN_ON(size > ringbuf->reserved_size);
> +     WARN_ON(ringbuf->reserved_in_use);
> +
> +     ringbuf->reserved_in_use = true;
> +     ringbuf->reserved_tail   = ringbuf->tail;
> +}
> +
> +void intel_ring_reserved_space_end(struct intel_ringbuffer *ringbuf)
> +{
> +     WARN_ON(!ringbuf->reserved_in_use);
> +     WARN_ON(ringbuf->tail > ringbuf->reserved_tail + 
> ringbuf->reserved_size);

Don't we need to handle wrap-around to make sure we do correctly check for
sufficient reservation?
-Daniel
-- 
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/intel-gfx

Reply via email to