On Tue, Jun 17, 2014 at 04:14:37PM +0200, Daniel Vetter wrote:
> Queued for -next, thanks for the patch. Aside: Checkpatch complained about
> some unaligned function parameters. Please try to get that right for the
> next patch since it really helps with readability. Fixed up while
> applying.

Oh well, I have a slight refinement because I grew tired of seeing
spurious syncs being reported:

> > -   ret = dev_priv->display.queue_flip(dev, crtc, fb, obj, ring, 
> > page_flip_flags);
> > +   if (use_mmio_flip(ring, obj))

Just before this point we call pin_and_fence, but really we want to do
so here instead with

pin_and_fence(obj, obj->ring);
work->gtt_offset = blah;

> > +           ret = intel_queue_mmio_flip(dev, crtc, fb, obj, ring,
> > +                           page_flip_flags);
> > +   else

and

pin_and_fence(obj, ring);
work->gtt_offset = blah;

here
> > +           ret = dev_priv->display.queue_flip(dev, crtc, fb, obj, ring,
> > +                           page_flip_flags);
> >     if (ret)
> >             goto cleanup_unpin;

-- 
Chris Wilson, Intel Open Source Technology Centre
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/intel-gfx

Reply via email to