> +/* subbuf_start callback wrapper */
> +static int cb_subbuf_start(struct rchan_buf *buf, void *subbuf,
> +                        void *prev_subbuf, size_t prev_padding)

I don't think the comment adds any information over just looking at the
function and the two callers.  I'd also name it relay_subbuf_start
instead of the cb_ prefix not used anywhere else in the file.


>  {
> +     if (buf->chan->cb->subbuf_start)
> +             return buf->chan->cb->subbuf_start(buf, subbuf,
> +                                                prev_subbuf, prev_padding);
> +
>       if (relay_buf_full(buf))
>               return 0;

This could also be simplified a bit more to:

        if (!buf->chan->cb->subbuf_start)
                return !relay_buf_full(buf);
        return buf->chan->cb->subbuf_start(buf, subbuf, prev_subbuf,
                                           prev_padding);

Otherwise this looks good to me:

Reviewed-by: Christoph Hellwig <h...@lst.de>
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

Reply via email to