On Fri, 02 Nov 2012 05:29:10 +0100
Mario Kleiner <mario.klei...@tuebingen.mpg.de> wrote:

> On 30.10.12 19:33, Jesse Barnes wrote:
> > This lets us pass down flags the drivers might be interested in, e.g. async.
> >
> > Signed-off-by: Jesse Barnes <jbar...@virtuousgeek.org>
> 
> Hi Jesse
> 
> I like it :) -- Anything that helps to get rid of the troublesome 
> 'SwapBuffersWait' madness in the ddx at some point makes me happy.
> 
> > diff --git a/drivers/gpu/drm/drm_crtc.c b/drivers/gpu/drm/drm_crtc.c
> > index ef1b221..b4964ac 100644
> > --- a/drivers/gpu/drm/drm_crtc.c
> > +++ b/drivers/gpu/drm/drm_crtc.c
> > @@ -3627,7 +3627,7 @@ int drm_mode_page_flip_ioctl(struct drm_device *dev,
> >                     (void (*) (struct drm_pending_event *)) kfree;
> >     }
> >
> > -   ret = crtc->funcs->page_flip(crtc, fb, e);
> > +   ret = crtc->funcs->page_flip(crtc, fb, e, flags);
> 
> I think this should be page_flip->flags, ie.
> 
> +     ret = crtc->funcs->page_flip(crtc, fb, e, page_flip->flags);
> 
> because flags is used here:
> 
> >     if (ret) {
> >             if (page_flip->flags & DRM_MODE_PAGE_FLIP_EVENT) {
> >                     spin_lock_irqsave(&dev->event_lock, flags);
> 
> to spin_lock_irqsave.
> 
> As a tiny nit-pick, you sometimes name the variable 'flags', sometimes 
> 'flip_flags' in the different kms implementations below, which could be 
> made consistent.
> 
> Reviewed-by: mario.klei...@tuebingen.mpg.de
> 

Yeah thanks.  After I used 'flags' everywhere I saw the locking ones
and changed some, but obviously didn't catch them all. :)

I'll fix things up to be more consistent.

Thanks,
-- 
Jesse Barnes, Intel Open Source Technology Center
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/intel-gfx

Reply via email to