The ultimate goal of this series is to promote our definition
of fixed16.16 type to include/linux. However, before doing so
we need to do some preparations/cleanups locally.

Note that some helper functions may require additional renames.
Any suggestions are welcomed.

Suggested-by: Chris Wilson <ch...@chris-wilson.co.uk>
Cc: Chris Wilson <ch...@chris-wilson.co.uk>
Cc: Rodrigo Vivi <rodrigo.v...@intel.com>
Cc: Joonas Lahtinen <joonas.lahti...@linux.intel.com>
Cc: Mahesh Kumar <mahesh1.ku...@intel.com>
Cc: Maarten Lankhorst <maarten.lankho...@linux.intel.com>

Michal Wajdeczko (5):
  drm/i915: Move uint_fixed_16_16_t to its own header
  drm/i915: Rename uint_fixed_16_16_t to fixed16_16_t
  drm/i915: Add common fixed16_16 values
  drm/i915: Fix overflows in fixed16_16
  drm/i915: Tidy up fixed16_16

 drivers/gpu/drm/i915/fixed16_16.h | 164 ++++++++++++++++++++++++++++++++++++++
 drivers/gpu/drm/i915/i915_drv.h   | 143 +--------------------------------
 drivers/gpu/drm/i915/intel_pm.c   |  68 ++++++++--------
 3 files changed, 201 insertions(+), 174 deletions(-)
 create mode 100644 drivers/gpu/drm/i915/fixed16_16.h

-- 
1.9.1

_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

Reply via email to