On Tue, Mar 21, 2017 at 09:13:51AM +0100, Thierry Reding wrote:
> From: Thierry Reding <tred...@nvidia.com>
> 
> Add a couple of temporary variables and use shorter names for existing
> variables in drm_fb_helper_add_one_connector() for better readability.
> 
> Tested-by: John Stultz <john.stu...@linaro.org>
> Signed-off-by: Thierry Reding <tred...@nvidia.com>
> ---
>  drivers/gpu/drm/drm_fb_helper.c | 25 ++++++++++++++++---------
>  1 file changed, 16 insertions(+), 9 deletions(-)
> 
> diff --git a/drivers/gpu/drm/drm_fb_helper.c b/drivers/gpu/drm/drm_fb_helper.c
> index 875a49048222..17fd98fe4a1f 100644
> --- a/drivers/gpu/drm/drm_fb_helper.c
> +++ b/drivers/gpu/drm/drm_fb_helper.c
> @@ -109,31 +109,38 @@ static DEFINE_MUTEX(kernel_fb_helper_lock);
>       for (({ lockdep_assert_held(&(fbh)->dev->mode_config.mutex); }), \
>            i__ = 0; i__ < (fbh)->connector_count; i__++)
>  
> -int drm_fb_helper_add_one_connector(struct drm_fb_helper *fb_helper, struct 
> drm_connector *connector)
> +int drm_fb_helper_add_one_connector(struct drm_fb_helper *fb_helper,
> +                                 struct drm_connector *connector)
>  {
>       struct drm_fb_helper_connector **temp;
> -     struct drm_fb_helper_connector *fb_helper_connector;
> +     struct drm_fb_helper_connector *conn;

I'd go with fb_conn here. Still short, but avoids confusion with
drm_connector, which is what we usually call conn. Either way:

Reviewed-by: Daniel Vetter <daniel.vet...@ffwll.ch>

> +     unsigned int count;
>  
>       if (!drm_fbdev_emulation)
>               return 0;
>  
>       WARN_ON(!mutex_is_locked(&fb_helper->dev->mode_config.mutex));
> -     if (fb_helper->connector_count + 1 > 
> fb_helper->connector_info_alloc_count) {
> -             temp = krealloc(fb_helper->connector_info, sizeof(struct 
> drm_fb_helper_connector *) * (fb_helper->connector_count + 1), GFP_KERNEL);
> +
> +     count = fb_helper->connector_count + 1;
> +
> +     if (count > fb_helper->connector_info_alloc_count) {
> +             size_t size = count * sizeof(conn);
> +
> +             temp = krealloc(fb_helper->connector_info, size, GFP_KERNEL);
>               if (!temp)
>                       return -ENOMEM;
>  
> -             fb_helper->connector_info_alloc_count = 
> fb_helper->connector_count + 1;
> +             fb_helper->connector_info_alloc_count = count;
>               fb_helper->connector_info = temp;
>       }
>  
> -     fb_helper_connector = kzalloc(sizeof(struct drm_fb_helper_connector), 
> GFP_KERNEL);
> -     if (!fb_helper_connector)
> +     conn = kzalloc(sizeof(*conn), GFP_KERNEL);
> +     if (!conn)
>               return -ENOMEM;
>  
>       drm_connector_get(connector);
> -     fb_helper_connector->connector = connector;
> -     fb_helper->connector_info[fb_helper->connector_count++] = 
> fb_helper_connector;
> +     conn->connector = connector;
> +     fb_helper->connector_info[fb_helper->connector_count++] = conn;
>       return 0;
>  }
>  EXPORT_SYMBOL(drm_fb_helper_add_one_connector);
> -- 
> 2.12.0
> 
> _______________________________________________
> dri-devel mailing list
> dri-de...@lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/dri-devel

-- 
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

Reply via email to