On Thu, 12 May 2011 22:17:16 +0100, Chris Wilson <ch...@chris-wilson.co.uk> wrote:
> Keith complained that GMBUSx + reg_offset was ugly. An alternative > naming scheme which is more consistent with the reset of the code base > is to store the address of the GMBUS0 and then reference each of the > GMBUSx registers as an offset from GMBUS0. This looks completely wrong -- GMBUS1 is GMBUS0 + 4, not GMBUS0 + 1. How about a simple function that computes the GMBUS register address based on the device and a number? like: static int intel_gmbus_reg(struct drm_device *dev, int reg) { int base = HAS_PCH_SPLIT(dev) ? PCH_GMBUS0 : GMBUS0; return base + reg * 4; } -- keith.pack...@intel.com
pgpK3H5sgznvC.pgp
Description: PGP signature
_______________________________________________ Intel-gfx mailing list Intel-gfx@lists.freedesktop.org http://lists.freedesktop.org/mailman/listinfo/intel-gfx