Cycles with 'Iterator' are error-prone. It's better to use more high-level code, which easier to read. We can use enhanced-for or Collection.removeIf
------------- Commit messages: - [PATCH] Cleanup Iterator usages in java.desktop - [PATCH] Cleanup Iterator usages in java.desktop Changes: https://git.openjdk.java.net/jdk/pull/5871/files Webrev: https://webrevs.openjdk.java.net/?repo=jdk&pr=5871&range=00 Issue: https://bugs.openjdk.java.net/browse/JDK-8275106 Stats: 115 lines in 18 files changed: 5 ins; 62 del; 48 mod Patch: https://git.openjdk.java.net/jdk/pull/5871.diff Fetch: git fetch https://git.openjdk.java.net/jdk pull/5871/head:pull/5871 PR: https://git.openjdk.java.net/jdk/pull/5871