looks like a very good idea, does this mean people don't need to do this (taken from docs): "It is critical that batchSize in the previous example matches the batch_size value described previously." ? Should we remove the option and references from documentation?
2008/6/21 Emmanuel Bernard <[EMAIL PROTECTED]>: > I never liked the way we work around mass insertion and OOME today > > hibernate.search.worker.batch_size has many drawbacks - the value is not > accessible programatically - it applies to any operations regardless of mass > indexing - it is used 99% of the time in close conjunction with a % and > session.clear() - the side effect is quite big as the index is > "transactionally" committed To replace it, I introduced > session.flushToIndexes(); this method manually triggers changes in queue. It > does not trigger an hibernate core flush(). This seems more reasonable and > will make the code safer. WDYT? Better name? > -- > Emmanuel Bernard > [EMAIL PROTECTED] > http://in.relation.to > http://blog.emmanuelbernard.com > http://twitter.com/emmanuelbernard > > > _______________________________________________ > hibernate-dev mailing list > hibernate-dev@lists.jboss.org > https://lists.jboss.org/mailman/listinfo/hibernate-dev > >
_______________________________________________ hibernate-dev mailing list hibernate-dev@lists.jboss.org https://lists.jboss.org/mailman/listinfo/hibernate-dev