And here is another thing I'd like to see: When learning cf3, I always
had problems figuring out which names were part of the language and
which were user defined. For example, my previous example read:
...
      depth_search => recurse,
...
body depth_search recurse {
   depth => "inf";
}

I always had to think twice about terms like "recurse" - is it a part
of the language or not? This is easy to fix (and I have done this
across all my cf3 code) - just prefix every non-cf3 term with
something that is clearly not part of the language. In my case I use a
company specific string, for example "xyz_recurse".  Another approach
is use use for example "my_recurse" - also very clearly not part of
cf3.

Here's an existing example from the tutorial[1]:
...
perms => m("600"),
copy_from => remote_cp("$(master_location)","localhost"),
depth_search => recurse("inf"),
action => immediate;
...

For the beginner (and myself...), the following is easier to read:
...
  perms => my_mode("600"),
  copy_from => my_remote_cp("$(master_location)","localhost"),
  depth_search => my_recurse("inf"),
  action => immediate;
...
This would also be nice to have for the common body library, meaning
that each body or bundle for example had a copbl_ prefix:

- body acl copbl_access_generic
- body acl copbl_ntfs
- body acl copbl_strict
- body action copbl_bg
- body action copbl_if_elapsed
- body action copbl_ifwin_bg
...

- Erlend


[1]: http://cfengine.com/manuals/cf3-tutorial.html#Remote-file-distribution
_______________________________________________
Help-cfengine mailing list
Help-cfengine@cfengine.org
https://cfengine.org/mailman/listinfo/help-cfengine

Reply via email to