Nemo Chen created HDFS-10749: -------------------------------- Summary: Log refactoring: method invocation should be replaced by variable Key: HDFS-10749 URL: https://issues.apache.org/jira/browse/HDFS-10749 Project: Hadoop HDFS Issue Type: Bug Affects Versions: 2.7.2 Reporter: Nemo Chen
Similar to the fix for HDFS-409. In file: hadoop-rel-release-2.7.2/hadoop-hdfs-project/hadoop-hdfs/src/main/java/org/apache/hadoop/hdfs/DFSOutputStream.java In code block: {code:borderStyle=solid} lastQueuedSeqno = currentPacket.getSeqno(); if (DFSClient.LOG.isDebugEnabled()) { DFSClient.LOG.debug("Queued packet " + currentPacket.getSeqno()); } {code} currentPacket.getSeqno() is better to be replaced by variable lastQueuedSeqno. -- This message was sent by Atlassian JIRA (v6.3.4#6332) --------------------------------------------------------------------- To unsubscribe, e-mail: hdfs-dev-unsubscr...@hadoop.apache.org For additional commands, e-mail: hdfs-dev-h...@hadoop.apache.org