Anton Avtamonov wrote: > On 4/21/06, Tim Ellison <[EMAIL PROTECTED]> wrote: <snip> >> I'd prefer the module name '.', i.e. beans.1, beans.2, and so on. > > I'm not sure. Module name IMHO doesn't make too much sense since it is > already 'coded' into accessor location and class location. I would > prefer <class_name>.<message intention> like > RandomAccessFile.file_is_closed > or something similar which keeps the idea of what the message is about. > > That requires a bit more efforts but makes the code understandable.
I'd be inclined to agree, but using long key String turned out to be one of the top Eclipse performance bloopers [1] so we actually need to keep them short. [1] http://www.eclipse.org/eclipse/development/performance/bloopers.html (page down to "Message catalog keys") Regards, Tim -- Tim Ellison ([EMAIL PROTECTED]) IBM Java technology centre, UK. --------------------------------------------------------------------- Terms of use : http://incubator.apache.org/harmony/mailing.html To unsubscribe, e-mail: [EMAIL PROTECTED] For additional commands, e-mail: [EMAIL PROTECTED]
