I also agree. The only 'requirement' I would add is that it should be possible to do such mark-up on per-check basis rather than per-test_method or even per-test_class basic. Because each testMehtod() may have several checks only few of them will be harmony-dependent.
-- Anton Avtamonov, Intel Middleware Products Division On 4/17/06, Andrew Zhang <[EMAIL PROTECTED]> wrote: > +1. Annotation is a good way to deliver such information. > > > > On 4/17/06, Paulex Yang <[EMAIL PROTECTED]> wrote: > > > > I consider the isHarmony() should be metadata, I have concerns to hard > > code in test cases. How about mark these test cases as "non-compatible" > > by annotation, by naming convention or more directly by some list, and > > use test script to handle them? > > > -- > > > Anton Avtamonov, > > > Intel Middleware Products Division > > > > > > --------------------------------------------------------------------- > > > Terms of use : http://incubator.apache.org/harmony/mailing.html > > > To unsubscribe, e-mail: [EMAIL PROTECTED] > > > For additional commands, e-mail: [EMAIL PROTECTED] > > > > > > > > > > > > > > > -- > > Paulex Yang > > China Software Development Lab > > IBM > > > > > > > > --------------------------------------------------------------------- > > Terms of use : http://incubator.apache.org/harmony/mailing.html > > To unsubscribe, e-mail: [EMAIL PROTECTED] > > For additional commands, e-mail: [EMAIL PROTECTED] > > > > > > > -- > Andrew Zhang > China Software Development Lab, IBM > > --------------------------------------------------------------------- Terms of use : http://incubator.apache.org/harmony/mailing.html To unsubscribe, e-mail: [EMAIL PROTECTED] For additional commands, e-mail: [EMAIL PROTECTED]
