On 2009 Nov 16, at 16:43, Przemysław Czerpak wrote: > On Mon, 16 Nov 2009, vszak...@users.sourceforge.net wrote: >> 2009-11-16 11:26 UTC+0100 Viktor Szakats (harbour.01 syenar.hu) >> * Changed USHORT type for error codes to HB_ERRCODE. >> + More or less changed int type of Extend/Item API call to >> long type to prepare for HB_ERRCODE change to ULONG. > > I think that HB_ERRCODE should be mapped to 32bit not 64 bit integer. > I do not see any place where we may need ULONG.
I didn't mean any 64-bit stuff here, I'm changing hb_parni() to hb_parnl() f.e. > >> ; TODO: Rename variables to reflect new type. >> ; TODO: Change internal error code from ULONG to HB_ERRCODE. >> ; TODO: Inspect rest of Harbour like above. I've only dealt with >> rtl, vm. >> ; TODO: hbnetio protocol needs to be modified to pass errcode >> as 32 bit value. >> ; NOTE: There is still disagreement in code in few places >> in error type and 'int' is used internally, f.e. >> sockets, some internal OS code conversion funtions. > > And it's fine. I do not find any problem here. > >> ; TODO: Different topic, but we use a lot of USHORTs to >> store modes, tries, severity, operation, flags and >> few other things which would better be stored as >> simple int probably. > > Yes it is and I hope that now you are seeing how complicated is such > modification and above is trivial job for few hours in comparison to > introducing HB_SIZE. Ops, this was to teach me a lesson?? I never told all aspects are trivial, but IMO it's doable and we should do it eventually. It may even reveal hidden bugs. Brgds, Viktor _______________________________________________ Harbour mailing list (attachment size limit: 40KB) Harbour@harbour-project.org http://lists.harbour-project.org/mailman/listinfo/harbour