Hi,
My question is whether to rename__AXGETCONTROL() to
WIN_AXATLGETCONTROL() ? Is this such a function which
users will want to (and can safely) use in their final apps?
If the return value is an obscure one, useful only for AX extensions
dealing with internals, I think we should keep the internal name.
In current code:
1) __AXGETCONTROL(), __OLECREATEOBJECT() and __OLEGETOBJECT() return
collectible IDispatch pointer;
2) WIN_AxGetControl(), WIN_OleCreateObject() and
WIN_OleGetActiveObject() return object.
So, it would be nice to have a compatible naming scheme for OLE and AX.
If you feel, you gonna use __AXGETOBJECT() in final applications, feel
free to rename.
Regards,
Mindaugas
_______________________________________________
Harbour mailing list
Harbour@harbour-project.org
http://lists.harbour-project.org/mailman/listinfo/harbour