if( !HB_PP_TOKEN_ISEOC( pToken ) || fUndef )
to:
if( !HB_PP_TOKEN_ISEOC( pToken ) )
If we decide to change it then probably it will be better to
make sth like:
if( fUndef )
lValue = 0;
else if( !HB_PP_TOKEN_ISEOC( pToken ) )
fError = TRUE;
In such for code like:
#if UNEXISTING_DEFINE == 0
#stdout "UNEXISTING_DEFINE is 0"
#endif
#stdout will not be compiled
Much better indeed.
So the question is:
- #if defined( HELLO ) .AND. HELLO > 100
vs.
- #if HELLO > 100
I tend to vote for the latter. Easier to write,
especially that ".AND." in a #define (which many
ppl will write as '&&' by mistake) can be avoided
this way.
Opinions from others?
Brgds,
Viktor
_______________________________________________
Harbour mailing list
Harbour@harbour-project.org
http://lists.harbour-project.org/mailman/listinfo/harbour