so I'd prefer sth different what will keep current PP syntax.
Even such minor modification resolved the problem.
DATA bDraw AS ?CODEBLOCK INIT nil
But we can also use sth what will allow to mix types, f.e.:
DATA bDraw AS CODEBLOCK | NIL
or we can support additionally: AS {<type> [,<type>]}, f.e.:
DATA bDraw AS {CODEBLOCK}
DATA bDraw AS {CODEBLOCK,NIL}
or maybe if possible, simply:
DATA bDraw AS CODEBLOCK, NIL
Otherwise:
DATA bDraw AS CODEBLOCK | NIL
"?CODEBLOCK", "CODEBLOCK?" looks very odd to me,
it also makes searching for code less efficient.
Think about it but base type checking should not be touched.
Otherwise IMO we should remove it at all because it stops to
give expected RT protection and we can keep it as source code
decoration just like in xHarbour.
Agreed.
Brgds,
Viktor
_______________________________________________
Harbour mailing list
Harbour@harbour-project.org
http://lists.harbour-project.org/mailman/listinfo/harbour