David Craven <da...@craven.ch> skribis: > * gnu/packages/wayland.scm (weston): New file. > * gnu/local.mk (GNU_PACKAGE_MODULES): Add it.
[...] > +(define-public cairo-xcb > + (package > + (inherit cairo) > + (name "cairo-xcb") > + (inputs > + `(("mesa" ,mesa) > + ,@(package-inputs cairo))) > + (arguments > + `(#:tests? #f > + #:configure-flags > + '("--enable-xlib-xcb" "--enable-gl" "--enable-egl"))))) Probably this should be kept next to ‘cairo’, and added as a separate patch. Also please change the synopsis to something like “2D graphics library (with X11 support)”. > +(define-public xwayland > + (package > + (inherit xorg-server) > + (name "xwayland") Should it be “xorg-server-xwayland”, since fundamentally it’s still the “xorg-server” source? > + (inputs > + `(("libepoxy" ,libepoxy) > + ("wayland" ,wayland) > + ,@(package-inputs xorg-server))) > + (arguments > + (substitute-keyword-arguments (package-arguments xorg-server) > + ((#:configure-flags flags) > + `(cons* "--enable-xwayland" "--disable-xorg" > + "--disable-docs" "--disable-devel-docs" > + "--disable-xvfb" "--disable-xnest" > + "--disable-xquartz" "--disable-xwin" > + ,flags)))))) Please add a synopsis (as above). > +(define-public weston > + (package > + (name "weston") > + (version "1.11.0") [...] > + (synopsis "Reference implementation of a Wayland compositor") What about “Reference Wayland graphical display server”? > + (description "Weston is the reference implementation of a Wayland > +compositor, and a useful compositor in its own right.") Maybe add a sentence about what a Wayland compositor does. Also I think people will prefer one patch per package. :-) Thank you! Ludo’.