Hi, These are generally useful x86-related changes which were originally posted as part of DRTM patchset [0]. The changes can also be viewed on GitHub [1].
Best regards, Sergii Changes in v2: - updated commit messages - added missing Signed-off-by Changes in v3: - patches 1-3: added reviewed-by - patch 6: updated commit message and made page mask signed - patch 7: more accurate commit message - patch 8: add overview of changes to commit message Changes in v4: - patches 1,4,5: updated commit messages - patches 1-6: added reviewed-by - patches 7,8: removed from the series to not add unused code [0]: https://lists.gnu.org/archive/html/grub-devel/2024-08/msg00088.html [1]: https://github.com/TrenchBoot/grub/compare/e1bee15...tb-generic-2.12-72-v4 Daniel Kiper (5): i386/msr: Merge rdmsr.h and wrmsr.h into msr.h i386/msr: Rename grub_msr_read() and grub_msr_write() i386/msr: Extract and improve MSR support detection code i386/memory: Rename PAGE_SHIFT to GRUB_PAGE_SHIFT i386/memory: Rename PAGE_SIZE to GRUB_PAGE_SIZE and make it global Krystian Hebel (1): i386/memory: Define GRUB_PAGE_MASK and GRUB_PAGE_{UP,DOWN} macros grub-core/commands/i386/rdmsr.c | 25 ++++-------- grub-core/commands/i386/wrmsr.c | 25 ++++-------- grub-core/lib/i386/xen/relocator.S | 6 +-- grub-core/lib/x86_64/xen/relocator.S | 4 +- grub-core/loader/i386/xen.c | 61 ++++++++++++++-------------- include/grub/i386/memory.h | 8 +++- include/grub/i386/{wrmsr.h => msr.h} | 47 +++++++++++++++++++-- include/grub/i386/rdmsr.h | 37 ----------------- 8 files changed, 99 insertions(+), 114 deletions(-) rename include/grub/i386/{wrmsr.h => msr.h} (52%) delete mode 100644 include/grub/i386/rdmsr.h base-commit: 9c34d56c2dafcd2737db0e3e49df63bce4d8b504 prerequisite-patch-id: 9255568f81dbfebc40e49a086e40c643ce2e79b9 -- 2.46.2 _______________________________________________ Grub-devel mailing list Grub-devel@gnu.org https://lists.gnu.org/mailman/listinfo/grub-devel