On 05.03.2012 12:16, Andreas Vogel wrote:
if [ "feature" = unavail ] ; then
set hidden=1
else
set hidden=0
fi
menuentry "Boot memtest86" --hidden $hidden { ... }
for looks nicer opposed to
if [ "feature" = unavail ] ; then
set hidden="--hidden"
else
set hidden=
fi
menuentry "Boot memtest86" $hidden { ... }
It's a question of personal preference and I personally prefer the
second one. And even if behaviour of optional arguments is changed it
doesn't mean that we should increase bitrot by having different
interface conventions for some options.
--
Regards
Vladimir 'φ-coder/phcoder' Serbinenko
_______________________________________________
Grub-devel mailing list
Grub-devel@gnu.org
https://lists.gnu.org/mailman/listinfo/grub-devel