On Mon, Aug 24, 2009 at 10:48:26PM +0200, Vladimir 'phcoder' Serbinenko wrote: > + int dy; > + for (dy = 0; dy < dh; dy++) > + { > + int dx; > + for (dx = 0; dx < dw; dx++) > + { > + grub_uint8_t *dptr; > + grub_uint8_t *sptr; > + int sx; > + int sy; > [...] > + grub_uint8_t f0y = (256 - v) * f00 / 256 + v * f01 / 256; > + grub_uint8_t f1y = (256 - v) * f10 / 256 + v * f11 / 256;
This kind of variable names make the code too cryptic. Please could you use more meaningful names? -- Robert Millan The DRM opt-in fallacy: "Your data belongs to us. We will decide when (and how) you may access your data; but nobody's threatening your freedom: we still allow you to remove your data and not access it at all." _______________________________________________ Grub-devel mailing list Grub-devel@gnu.org http://lists.gnu.org/mailman/listinfo/grub-devel