Latest interface my colleagues wrote (it's PHP)
---
interface UnreceivedMasterOrdersInterface
{
   public function getUnreceivedByProductsWarehouseAndCompany(array 
$productIds, int $warehouseId, int $companyId): array;
}
---
There is interest to switch to Go for some of the stuff we write, but I 
decided to leave before that happens. I like programming in Go for myself, 
and I don't want to start hating it because of nonsense like this.


On Wednesday, February 2, 2022 at 8:51:54 AM UTC+2 Amnon wrote:

> Idiomatic naming in Go is one of the hardest things to communicate.
> Everyone seems to bring the idioms from previous languages. Dave Cheney 
> writes about 
> "Lengthy bureaucratic names carry a low amount of signal compared to their 
> weight on the page".
> Identifiers are not sentences or stand alone stories. They are the the 
> basic building blocks for our code.
> We have all seen code infected by these names - long names leading to long 
> lines of code,
> and verbose walls of dense text, repetitive and hard to read.
>
> I always encourage people to read https://go.dev/doc/effective_go#names
> to study the Go standard library, and develop a feel of what Go code 
> should read like.
>
>
>>
>>

-- 
You received this message because you are subscribed to the Google Groups 
"golang-nuts" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to golang-nuts+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/golang-nuts/00dec58d-421a-4b86-9c15-6533fc648974n%40googlegroups.com.

Reply via email to