Is there a more concise way to write

       var check = 1 + self.left.itemCheck() + self.right.itemCheck()
       pool.Put(self.left)
       self.left = nil
       pool.Put(self.right)
       self.right = nil
       return check

-- 
You received this message because you are subscribed to the Google Groups 
"golang-nuts" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to golang-nuts+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to