Is there any reason that Cleanup(f) should be called within DoingStuff()? (A reason that maybe is not visible in your example but might become obvious in a more complex scenario?)
Otherwise you could just call `defer Cleanup(file)` in DoStuff() with exactly the same result, and you are back at the same-function logic that you want to escape from. -- You received this message because you are subscribed to the Google Groups "golang-nuts" group. To unsubscribe from this group and stop receiving emails from it, send an email to golang-nuts+unsubscr...@googlegroups.com. For more options, visit https://groups.google.com/d/optout.